multiple application sound in Fedora 7

Monday, September 3, 2007



one of the commenter john perez asked me about sound system in fedora 7, actually i have same problem like him, i can't have sound in mplayer when i view youtube video, but if i closed youtube website, i can play mplayer, the problem is i can't have multiple sound like before, i have to turn off another application that use sound system, anyway i found the solution to fixed this bug, from here..
linuxquestions.org - multi application sound
1.just copy this code to /etc/asound.conf (as root)

pcm.!default {
type plug
slave.pcm "swmixer"
}

pcm.swmixer {
type dmix
ipc_key 1234
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}
ctl.swmixer {
type hw
card 0
}
credit to dive
save it, and restart alsa sound with this command

/etc/init.d/alsasound restart

if u cant restart it, just relogout/ login again. then you can have sound system(minimize/bell) / audacious / youtube website playing sound together.

Posted by fedorasal at 9:38 AM  

4 comments:

Hello again,

In an attempt to fix my ALSA situation, I actually broke it. I reverted to ALSA 1.0.14 and applied the patch mentioned before and met some errors. I eventually fixed it by reinstalling my libasound2 packages.

Apparently, reinstalling them fixed everything. That includes the system sounds, online flash and multiple programs using ALSA simultaneously. Audio has no problems right now. Even the earphone jack works.

I hope this helps you too!

John Perez said...
September 5, 2007 at 7:16 AM  

thanks, maybe i will try it soon. :)

fedorasal said...
October 7, 2007 at 7:50 PM  

worked well for me, me being a new user was having a very bad time with the sound,;
now resolved

devilish said...
June 23, 2008 at 4:14 AM  
kimberly said...
June 14, 2010 at 10:41 AM  

Post a Comment